CRAN Package Check Results for Package frequency

Last updated on 2020-12-03 16:47:42 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.4.0 5.50 103.12 108.62 OK
r-devel-linux-x86_64-debian-gcc 0.4.0 5.27 76.53 81.80 OK
r-devel-linux-x86_64-fedora-clang 0.4.0 134.30 OK
r-devel-linux-x86_64-fedora-gcc 0.4.0 118.63 OK
r-devel-windows-ix86+x86_64 0.4.0 13.00 139.00 152.00 OK
r-patched-linux-x86_64 0.4.0 5.59 93.70 99.29 OK
r-patched-solaris-x86 0.4.0 90.90 ERROR
r-release-linux-x86_64 0.4.0 6.20 94.01 100.21 OK
r-release-macos-x86_64 0.4.0 ERROR
r-release-windows-ix86+x86_64 0.4.0 12.00 107.00 119.00 OK
r-oldrel-macos-x86_64 0.4.0 ERROR
r-oldrel-windows-ix86+x86_64 0.4.0 9.00 144.00 153.00 OK

Check Details

Version: 0.4.0
Check: tests
Result: ERROR
     Running ‘testthat.R’ [8s/10s]
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > Sys.setenv("R_TESTS" = "")
     > # Sys.setenv(LC_COLLATE = "C", LC_TIME = "C", LANGUAGE = "en")
     > Sys.setenv(LC_COLLATE = "C")
     >
     > print(Sys.getlocale(category = "LC_ALL"))
     [1] "/en_GB.UTF-8/C/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8"
     > Sys.setlocale("LC_COLLATE", "C") # R CMD check uses this default
     [1] "C"
     > # Sys.setlocale("LC_COLLATE", "en_US.UTF-8")
     > # Sys.setlocale("LC_COLLATE", "English_United States.1252")
     > print(Sys.getlocale(category = "LC_ALL"))
     [1] "/en_GB.UTF-8/C/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8"
     >
     > library(testthat)
     > library(frequency)
     Loading required package: rmarkdown
     Loading required package: knitr
     Loading required package: DT
     Loading required package: ggplot2
     > test_check("frequency")
     [1] "/en_GB.UTF-8/C/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8"
     [1] "/en_GB.UTF-8/C/en_GB.UTF-8/C/en_GB.UTF-8/en_GB.UTF-8"
     id test_numeric test_numeric_labelled
     1 1 100 1
     2 2 1000 2
     3 3 10000 2
     4 4 1 3
     5 5 1 3
     6 6 1 3
     7 7 100 4
     8 8 9 4
     9 9 99 4
     10 10 999 4
     11 11 9999 5
     12 12 99999 5
     13 13 999999 5
     14 14 100000 5
     15 15 1000000 5
     16 16 9 6
     17 17 123 7
     18 18 NA NA
     19 19 NA NA
     20 20 NA NA
     test_character
     1 VIC
     2 VIC
     3 NSW
     4 Vic
     5 WA
     6 WA
     7 TAS
     8 SA
     9 VIC
     10 ACT
     11 ACT
     12 QLD
     13 NT
     14 NULL
     15 NA
     16 Not Stated
     17 Not Stated
     18
     19
     20 .
     test_character_labelled
     1 VIC
     2 VIC
     3 NSW
     4 Vic
     5 WA
     6 WA
     7 TAS
     8 SA
     9 VIC
     10 ACT
     11 ACT
     12 QLD
     13 NT
     14 NULL
     15 NA
     16 Not Stated
     17 Not Stated
     18
     19
     20 .
     'data.frame': 20 obs. of 5 variables:
     $ id : num 1 2 3 4 5 6 7 8 9 10 ...
     $ test_numeric : num 100 1000 10000 1 1 1 100 9 99 999 ...
     $ test_numeric_labelled : num 1 2 2 3 3 3 4 4 4 4 ...
     ..- attr(*, "value.labels")= Named chr [1:5] "5" "4" "3" "2" ...
     .. ..- attr(*, "names")= chr [1:5] "Five" "Four" "Three" "Two" ...
     $ test_character : Factor w/ 14 levels " ",..: 12 12 5 13 14 14 11 10 12 3 ...
     $ test_character_labelled: Factor w/ 14 levels " ",..: 12 12 5 13 14 14 11 10 12 3 ...
     - attr(*, "variable.labels")= Named chr [1:5] "" "Numeric Variable" "Partly Labelled Numeric Variable" "Character Variable" ...
     ..- attr(*, "names")= chr [1:5] "id" "test_numeric" "test_numeric_labelled" "test_character" ...
     - attr(*, "codepage")= int 65001
     NULL
     id test_numeric test_numeric_labelled
     1 1 100 1
     2 2 1000 2
     3 3 10000 2
     4 4 1 3
     5 5 1 3
     6 6 1 3
     7 7 100 4
     8 8 9 4
     9 9 99 4
     10 10 999 4
     11 11 9999 5
     12 12 99999 5
     13 13 999999 5
     14 14 100000 5
     15 15 1000000 5
     16 16 9 6
     17 17 123 7
     18 18 NA NA
     19 19 NA NA
     20 20 NA NA
     test_character
     1 VIC
     2 VIC
     3 NSW
     4 Vic
     5 WA
     6 WA
     7 TAS
     8 SA
     9 VIC
     10 ACT
     11 ACT
     12 QLD
     13 NT
     14 NULL
     15 NA
     16 Not Stated
     17 Not Stated
     18
     19
     20 .
     test_character_labelled
     1 VIC
     2 VIC
     3 NSW
     4 Vic
     5 WA
     6 WA
     7 TAS
     8 SA
     9 VIC
     10 ACT
     11 ACT
     12 QLD
     13 NT
     14 NULL
     15 NA
     16 Not Stated
     17 Not Stated
     18
     19
     20 .
     'data.frame': 20 obs. of 5 variables:
     $ id : num 1 2 3 4 5 6 7 8 9 10 ...
     $ test_numeric : num 100 1000 10000 1 1 1 100 9 99 999 ...
     $ test_numeric_labelled : num 1 2 2 3 3 3 4 4 4 4 ...
     ..- attr(*, "value.labels")= Named chr [1:5] "5" "4" "3" "2" ...
     .. ..- attr(*, "names")= chr [1:5] "Five" "Four" "Three" "Two" ...
     $ test_character : Factor w/ 14 levels " ",..: 12 12 5 13 14 14 11 10 12 3 ...
     $ test_character_labelled: Factor w/ 14 levels " ",..: 12 12 5 13 14 14 11 10 12 3 ...
     - attr(*, "variable.labels")= Named chr [1:5] "" "Numeric Variable" "Partly Labelled Numeric Variable" "Character Variable" ...
     ..- attr(*, "names")= chr [1:5] "id" "test_numeric" "test_numeric_labelled" "test_character" ...
     - attr(*, "codepage")= int 65001
     NULL
    
     |
     | | 0%
     |
     |============== | 20%
     |
     |============================ | 40%
     |
     |========================================== | 60%
     |
     |======================================================== | 80%
     |
     |======================================================================| 100%
     ── ERROR (tests.R:37:3): All ───────────────────────────────────────────────────
     Error: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Backtrace:
     █
     1. ├─testthat::expect_equal(raw_all, freq(dat)) tests.R:37:2
     2. │ └─testthat::quasi_label(enquo(expected), expected.label, arg = "expected")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─frequency::freq(dat)
     5. └─rmarkdown::render(...)
     6. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |======================================================================| 100%
     ── ERROR (tests.R:40:3): Individual tables ─────────────────────────────────────
     Error: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Backtrace:
     █
     1. ├─testthat::expect_equal(raw_id, freq(dat$id)) tests.R:40:2
     2. │ └─testthat::quasi_label(enquo(expected), expected.label, arg = "expected")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─frequency::freq(dat$id)
     5. └─rmarkdown::render(...)
     6. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
     [1] "Foreign: df vs list"
    
     |
     | | 0%
     |
     |============== | 20%
     |
     |============================ | 40%
     |
     |========================================== | 60%
     |
     |======================================================== | 80%
     |
     |======================================================================| 100%
     ── ERROR (tests.R:83:3): foreign_df vs foreign_list ────────────────────────────
     Error: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Backtrace:
     █
     1. ├─base::print(freq(foreign_df)) tests.R:83:2
     2. └─frequency::freq(foreign_df)
     3. └─rmarkdown::render(...)
     4. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:99:3): Arguments - x = ────────────────────────────────────
     `freq(df)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(df), NA) tests.R:99:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(df)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:104:3): Arguments - x = ───────────────────────────────────
     `freq(dat)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat), NA) tests.R:104:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:110:3): Arguments - x = ───────────────────────────────────
     `freq(vs)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(vs), NA) tests.R:110:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(vs)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:111:3): Arguments - x = ───────────────────────────────────
     `freq(vn)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(vn), NA) tests.R:111:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(vn)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
     ── Skip (tests.R:116:3): Arguments - file = ───────────────────────────────────
     Reason: On CRAN
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:148:3): Arguments - maxrow = ──────────────────────────────
     `freq(dat, maxrow = "5")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, maxrow = "5"), NA) tests.R:148:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, maxrow = "5")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:149:3): Arguments - maxrow = ──────────────────────────────
     `freq(dat, maxrow = "10")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, maxrow = "10"), NA) tests.R:149:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, maxrow = "10")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:150:3): Arguments - maxrow = ──────────────────────────────
     `freq(dat, maxrow = 5)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, maxrow = 5), NA) tests.R:150:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, maxrow = 5)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:151:3): Arguments - maxrow = ──────────────────────────────
     `freq(dat, maxrow = 10)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, maxrow = 10), NA) tests.R:151:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, maxrow = 10)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:152:3): Arguments - maxrow = ──────────────────────────────
     `freq(dat, maxrow = 100)` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, maxrow = 100), NA) tests.R:152:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, maxrow = 100)
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:163:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "doc")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "doc"), NA) tests.R:163:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "doc")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:164:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "docx")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "docx"), NA) tests.R:164:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "docx")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:165:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "html")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "html"), NA) tests.R:165:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "html")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:166:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "DOC")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "DOC"), NA) tests.R:166:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "DOC")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:167:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "DOCX")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "DOCX"), NA) tests.R:167:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "DOCX")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
    
     |
     | | 0%
     |
     |=================================== | 50%
     |
     |======================================================================| 100%
     ── FAILURE (tests.R:168:3): Arguments - type = ────────────────────────────────
     `freq(dat, type = "HTML")` threw an error.
     Message: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     Class: simpleError/error/condition
     Backtrace:
     █
     1. ├─testthat::expect_error(freq(dat, type = "HTML"), NA) tests.R:168:2
     2. │ └─testthat:::quasi_capture(...)
     3. │ ├─testthat:::.capture(...)
     4. │ │ └─base::withCallingHandlers(...)
     5. │ └─rlang::eval_bare(quo_get_expr(.quo), quo_get_env(.quo))
     6. └─frequency::freq(dat, type = "HTML")
     7. └─rmarkdown::render(...)
     8. └─rmarkdown::pandoc_available(required_pandoc, error = TRUE)
    
     ── Skipped tests ──────────────────────────────────────────────────────────────
     ● On CRAN (1)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     ERROR (tests.R:37:3): All
     ERROR (tests.R:40:3): Individual tables
     ERROR (tests.R:83:3): foreign_df vs foreign_list
     FAILURE (tests.R:99:3): Arguments - x =
     FAILURE (tests.R:104:3): Arguments - x =
     FAILURE (tests.R:110:3): Arguments - x =
     FAILURE (tests.R:111:3): Arguments - x =
     FAILURE (tests.R:148:3): Arguments - maxrow =
     FAILURE (tests.R:149:3): Arguments - maxrow =
     FAILURE (tests.R:150:3): Arguments - maxrow =
     FAILURE (tests.R:151:3): Arguments - maxrow =
     FAILURE (tests.R:152:3): Arguments - maxrow =
     FAILURE (tests.R:163:3): Arguments - type =
     FAILURE (tests.R:164:3): Arguments - type =
     FAILURE (tests.R:165:3): Arguments - type =
     FAILURE (tests.R:166:3): Arguments - type =
     FAILURE (tests.R:167:3): Arguments - type =
     FAILURE (tests.R:168:3): Arguments - type =
    
     [ FAIL 18 | WARN 0 | SKIP 1 | PASS 8 ]
     Error: Test failures
     Execution halted
Flavor: r-patched-solaris-x86

Version: 0.4.0
Check: tests
Result: ERROR
     Running ‘testthat.R’ [3s/4s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     ══ testthat results ═══════════════════════════════════════════════════════════
     [ OK: 8 | SKIPPED: 1 | WARNINGS: 0 | FAILED: 18 ]
     1. Error: All (@tests.R#37)
     2. Error: Individual tables (@tests.R#40)
     3. Error: foreign_df vs foreign_list (@tests.R#83)
     4. Failure: Arguments - x = (@tests.R#99)
     5. Failure: Arguments - x = (@tests.R#104)
     6. Failure: Arguments - x = (@tests.R#110)
     7. Failure: Arguments - x = (@tests.R#111)
     8. Failure: Arguments - maxrow = (@tests.R#148)
     9. Failure: Arguments - maxrow = (@tests.R#149)
     1. ...
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-macos-x86_64

Version: 0.4.0
Check: tests
Result: ERROR
     Running ‘testthat.R’ [4s/4s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     FAILURE (tests.R:148:3): Arguments - maxrow =
     FAILURE (tests.R:149:3): Arguments - maxrow =
     FAILURE (tests.R:150:3): Arguments - maxrow =
     FAILURE (tests.R:151:3): Arguments - maxrow =
     FAILURE (tests.R:152:3): Arguments - maxrow =
     FAILURE (tests.R:163:3): Arguments - type =
     FAILURE (tests.R:164:3): Arguments - type =
     FAILURE (tests.R:165:3): Arguments - type =
     FAILURE (tests.R:166:3): Arguments - type =
     FAILURE (tests.R:167:3): Arguments - type =
     FAILURE (tests.R:168:3): Arguments - type =
    
     [ FAIL 18 | WARN 0 | SKIP 1 | PASS 8 ]
     Error: Test failures
     Execution halted
Flavor: r-oldrel-macos-x86_64