CRAN Package Check Results for Package ggeffects

Last updated on 2022-01-23 07:14:00 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.1.1 11.32 350.05 361.37 OK
r-devel-linux-x86_64-debian-gcc 1.1.1 8.50 269.34 277.84 OK
r-devel-linux-x86_64-fedora-clang 1.1.1 420.92 OK
r-devel-linux-x86_64-fedora-gcc 1.1.1 425.52 OK
r-devel-windows-x86_64-new-UL 1.1.1 163.00 441.00 604.00 OK
r-devel-windows-x86_64-new-TK 1.1.1 ERROR
r-patched-linux-x86_64 1.1.1 10.33 334.28 344.61 OK
r-release-linux-x86_64 1.1.1 7.47 336.32 343.79 OK
r-release-macos-arm64 1.1.1 OK
r-release-macos-x86_64 1.1.1 OK
r-release-windows-ix86+x86_64 1.1.1 15.00 471.00 486.00 OK
r-oldrel-macos-x86_64 1.1.1 OK
r-oldrel-windows-ix86+x86_64 1.1.1 15.00 396.00 411.00 OK

Check Details

Version: 1.1.1
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'AER', 'effects', 'gamm4', 'glmmTMB', 'lme4', 'rstanarm', 'sjstats'
Flavor: r-devel-windows-x86_64-new-TK

Version: 1.1.1
Check: tests
Result: ERROR
     Running 'testthat.R'
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > if (require("testthat")) {
     + library(ggeffects)
     +
     + if (length(strsplit(packageDescription("ggeffects")$Version, "\\.")[[1]]) > 3) {
     + Sys.setenv("RunAllggeffectsTests" = "yes")
     + } else {
     + Sys.setenv("RunAllggeffectsTests" = "no")
     + }
     +
     +
     + si <- Sys.info()
     +
     + osx <- tryCatch(
     + {
     + if (!is.null(si["sysname"])) {
     + si["sysname"] == "Darwin" || grepl("^darwin", R.version$os)
     + } else {
     + FALSE
     + }
     + },
     + error = function(e) {
     + FALSE
     + }
     + )
     +
     +
     + solaris <- tryCatch(
     + {
     + if (!is.null(si["sysname"])) {
     + grepl("SunOS", si["sysname"], ignore.case = TRUE)
     + } else {
     + FALSE
     + }
     + },
     + error = function(e) {
     + FALSE
     + }
     + )
     +
     + if (!osx && !solaris) {
     + test_check("ggeffects")
     + }
     + }
     Loading required package: testthat
     Loading required package: gam
     Loading required package: splines
     Loading required package: foreach
     Loaded gam 1.20
    
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Loading required namespace: emmeans
     Loading required package: emmeans
     Loading required package: effects
     Loading required package: lme4
     Loading required package: lme4
     Loading required package: lme4
     Loading required package: lme4
     Loading required package: survival
     Loading required package: gee
     (Intercept) tensionM tensionH
     36.38889 -10.00000 -14.72222
     Loading required package: geepack
     Loading required package: haven
     Loading required package: sjlabelled
    
     Attaching package: 'sjlabelled'
    
     The following objects are masked from 'package:haven':
    
     as_factor, read_sas, read_spss, read_stata, write_sas, zap_labels
    
     Loading required package: sjmisc
     Loading required package: lme4
     Loading required package: robustbase
    
     Attaching package: 'robustbase'
    
     The following object is masked from 'package:survival':
    
     heart
    
     Data were 'prettified'. Consider using `terms="c12hour [all]"` to get smooth plots.
     Data were 'prettified'. Consider using `terms="c12hour [all]"` to get smooth plots.
     Can't compute estimated marginal means, 'emmeans::emmeans()' returned an error.
    
     Reason: Can't handle an object of class "glmrob"
     Use help("models", package = "emmeans") for information on supported models.
     You may try 'ggpredict()' or 'ggeffect()'.
    
     Loading required package: effects
     Loading required package: effects
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Can't compute estimated marginal means, 'emmeans::emmeans()' returned an error.
    
     Reason: Can't handle an object of class "lmrob"
     Use help("models", package = "emmeans") for information on supported models.
     You may try 'ggpredict()' or 'ggeffect()'.
    
     Loading required package: logistf
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Can't compute estimated marginal means, 'emmeans::emmeans()' returned an error.
    
     Reason: Can't handle an object of class "logistf"
     Use help("models", package = "emmeans") for information on supported models.
     You may try 'ggpredict()' or 'ggeffect()'.
    
     Loading required package: rms
     Loading required package: Hmisc
     Loading required package: lattice
     Loading required package: Formula
     Loading required package: ggplot2
    
     Attaching package: 'ggplot2'
    
     The following object is masked from 'package:sjlabelled':
    
     as_label
    
    
     Attaching package: 'Hmisc'
    
     The following object is masked from 'package:sjmisc':
    
     %nin%
    
     The following object is masked from 'package:testthat':
    
     describe
    
     The following objects are masked from 'package:base':
    
     format.pval, units
    
     Loading required package: SparseM
    
     Attaching package: 'SparseM'
    
     The following object is masked from 'package:base':
    
     backsolve
    
    
     Attaching package: 'rms'
    
     The following object is masked from 'package:emmeans':
    
     contrast
    
     Data were 'prettified'. Consider using `terms="c12hour [all]"` to get smooth plots.
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Data were 'prettified'. Consider using `terms="c12hour [all]"` to get smooth plots.
     Data were 'prettified'. Consider using `terms="c12hour [all]"` to get smooth plots.
     Loading required package: MASS
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Loading required package: nlme
     Loading required package: lme4
     Loading required package: pscl
     Classes and Methods for R developed in the
     Political Science Computational Laboratory
     Department of Political Science
     Stanford University
     Simon Jackman
     hurdle and zeroinfl functions by Achim Zeileis
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Loading required package: effects
     Loading required package: glmmTMB
     Loading required package: quantreg
    
     Attaching package: 'quantreg'
    
     The following object is masked from 'package:Hmisc':
    
     latex
    
     The following object is masked from 'package:survival':
    
     untangle.specials
    
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Can't compute estimated marginal means, 'emmeans::emmeans()' returned an error.
    
     Reason: No coefficients available for tau = 0.5
     You may try 'ggpredict()' or 'ggeffect()'.
    
     Loading required package: survey
     Loading required package: grid
     Loading required package: Matrix
    
     Attaching package: 'survey'
    
     The following object is masked from 'package:rms':
    
     calibrate
    
     The following object is masked from 'package:Hmisc':
    
     deff
    
     The following object is masked from 'package:graphics':
    
     dotchart
    
     Loading required package: sjstats
     Package `effects` is not available, but needed for `ggeffect()`. Either install package `effects`, or use `ggpredict()`. Calling `ggpredict()` now.FALSE
     Loading required package: sjstats
     Loading required package: AER
     Loading required package: VGAM
     Loading required package: stats4
    
     Attaching package: 'VGAM'
    
     The following object is masked from 'package:survey':
    
     calibrate
    
     The following objects are masked from 'package:rms':
    
     calibrate, lrtest
    
     Loading required package: glmmTMB
     [ FAIL 5 | WARN 3 | SKIP 1 | PASS 71 ]
    
     ══ Skipped tests ═══════════════════════════════════════════════════════════════
     • empty test (1)
    
     ══ Failed tests ════════════════════════════════════════════════════════════════
     ── Failure (test-Gam2.R:19:5): ggeffect ────────────────────────────────────────
     p$predicted[1] (`actual`) not equal to 0.106151 (`expected`).
    
     `actual`: 0.02
     `expected`: 0.11
     ── Failure (test-logistf.R:16:5): ggeffect, logistf ────────────────────────────
     pr$predicted[1] (`actual`) not equal to 0.5762638 (`expected`).
    
     `actual`: 0.5764
     `expected`: 0.5763
     ── Failure (test-lrm.R:18:5): ggeffect, lrm ────────────────────────────────────
     ggeffect(m1, "c12hour") is not NULL
    
     `actual` is an S3 object of class <ggeffects/data.frame>, a list
     `expected` is NULL
     ── Failure (test-rq.R:17:5): ggeffect, rq ──────────────────────────────────────
     ggeffect(m1, "Air.Flow") is not NULL
    
     `actual` is an S3 object of class <ggeffects/data.frame>, a list
     `expected` is NULL
     ── Failure (test-survreg.R:17:5): ggeffect, survreg ────────────────────────────
     ggeffect(m1, "ecog.ps") is not NULL
    
     `actual` is an S3 object of class <ggeffects/data.frame>, a list
     `expected` is NULL
    
     [ FAIL 5 | WARN 3 | SKIP 1 | PASS 71 ]
     Error: Test failures
     Execution halted
Flavor: r-devel-windows-x86_64-new-TK