CRAN Package Check Results for Maintainer ‘Jonas Glatthorn <jonas.glatthorn at posteo.de>’

Last updated on 2022-08-14 11:06:50 CEST.

Package WARN OK
APAtree 2 11

Package APAtree

Current CRAN status: WARN: 2, OK: 11

Additional issues

clang14

Version: 1.0.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     get_subplot_boundary_pixels.cpp:37:10: warning: use of bitwise '|' with boolean operands [-Wbitwise-instead-of-logical]
     polygonize_class.cpp:52:10: warning: use of bitwise '&' with boolean operands [-Wbitwise-instead-of-logical]
     polygonize_class.cpp:78:16: warning: use of bitwise '&' with boolean operands [-Wbitwise-instead-of-logical]
     polygonize_class.cpp:99:11: warning: use of bitwise '|' with boolean operands [-Wbitwise-instead-of-logical]
     polygonize_class.cpp:102:12: warning: use of bitwise '&' with boolean operands [-Wbitwise-instead-of-logical]
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-fedora-clang