CRAN Package Check Results for Package pomdp

Last updated on 2019-09-22 14:47:35 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.9.1-1 24.56 31.96 56.52 OK
r-devel-linux-x86_64-debian-gcc 0.9.1-1 17.38 25.55 42.93 WARN
r-devel-linux-x86_64-fedora-clang 0.9.1-1 73.81 OK
r-devel-linux-x86_64-fedora-gcc 0.9.1-1 71.85 WARN
r-devel-windows-ix86+x86_64 0.9.1-1 109.00 63.00 172.00 OK
r-patched-linux-x86_64 0.9.1-1 19.17 31.16 50.33 OK
r-patched-solaris-x86 0.9.1-1 95.30 OK
r-release-linux-x86_64 0.9.1-1 18.39 31.73 50.12 OK
r-release-windows-ix86+x86_64 0.9.1-1 76.00 63.00 139.00 OK
r-release-osx-x86_64 0.9.1-1 OK
r-oldrel-windows-ix86+x86_64 0.9.1-1 75.00 63.00 138.00 OK
r-oldrel-osx-x86_64 0.9.1-1 OK

Check Details

Version: 0.9.1-1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     lpkit.c:632:9: warning: ‘strcpy’ accessing 1 byte at offsets [-4611686018427387904, 4611686018427387903] and [-4611686018427387904, 4611686018427387903] may overlap 1 byte at offset -4611686018427387904 [-Wrestrict]
     lpkit.c:790:9: warning: ‘strcpy’ accessing 1 byte at offsets [-4611686018427387904, 4611686018427387903] and [-4611686018427387904, 4611686018427387903] may overlap 1 byte at offset -4611686018427387904 [-Wrestrict]
Flavor: r-devel-linux-x86_64-debian-gcc

Version: 0.9.1-1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     /usr/include/bits/string_fortified.h:90:10: warning: ‘__builtin_strcpy’ accessing 1 byte at offsets [-4611686018427387904, 4611686018427387903] and [-4611686018427387904, 4611686018427387903] may overlap 1 byte at offset -4611686018427387904 [-Wrestrict]
Flavor: r-devel-linux-x86_64-fedora-gcc