CRAN Package Check Results for Package smoothSurv

Last updated on 2020-02-23 10:49:05 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.1 55.50 73.34 128.84 WARN
r-devel-linux-x86_64-debian-gcc 2.1 37.98 56.73 94.71 OK
r-devel-linux-x86_64-fedora-clang 2.1 180.72 WARN
r-devel-linux-x86_64-fedora-gcc 2.1 162.23 OK
r-devel-windows-ix86+x86_64 2.1 96.00 108.00 204.00 OK
r-devel-windows-ix86+x86_64-gcc8 2.1 102.00 147.00 249.00 OK
r-patched-linux-x86_64 2.1 OK
r-patched-solaris-x86 2.1 163.50 OK
r-release-linux-x86_64 2.1 37.27 67.01 104.28 OK
r-release-windows-ix86+x86_64 2.1 82.00 99.00 181.00 OK
r-release-osx-x86_64 2.1 WARN
r-oldrel-windows-ix86+x86_64 2.1 90.00 103.00 193.00 OK
r-oldrel-osx-x86_64 2.1 WARN

Check Details

Version: 2.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Scythe_IDE.cpp:70:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:107:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:108:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:109:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:147:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:148:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:149:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:189:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:211:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:212:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:262:3: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:265:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
     ./Scythe_IDE.cpp:266:4: warning: 'register' storage class specifier is deprecated and incompatible with C++17 [-Wdeprecated-register]
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64