CRAN Package Check Results for Package stringi

Last updated on 2019-08-26 10:48:29 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.4.3 95.23 48.26 143.49 OK
r-devel-linux-x86_64-debian-gcc 1.4.3 60.11 38.33 98.44 OK
r-devel-linux-x86_64-fedora-clang 1.4.3 254.58 NOTE
r-devel-linux-x86_64-fedora-gcc 1.4.3 185.87 OK
r-devel-windows-ix86+x86_64 1.4.3 1892.00 159.00 2051.00 WARN
r-patched-linux-x86_64 1.4.3 75.22 47.73 122.95 OK
r-patched-solaris-x86 1.4.3 860.90 NOTE
r-release-linux-x86_64 1.4.3 75.30 47.97 123.27 OK
r-release-windows-ix86+x86_64 1.4.3 1183.00 152.00 1335.00 NOTE
r-release-osx-x86_64 1.4.3 NOTE
r-oldrel-windows-ix86+x86_64 1.4.3 1184.00 136.00 1320.00 NOTE
r-oldrel-osx-x86_64 1.4.3 NOTE

Additional issues

clang-UBSAN gcc-UBSAN rchk

Check Details

Version: 1.4.3
Check: installed package size
Result: NOTE
     installed size is 5.5Mb
     sub-directories of 1Mb or more:
     libs 4.8Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-x86, r-release-windows-ix86+x86_64, r-release-osx-x86_64, r-oldrel-windows-ix86+x86_64, r-oldrel-osx-x86_64

Version: 1.4.3
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     icu61/i18n/decNumber.cpp:1524:13: warning: array subscript is above array bounds [-Warray-bounds]
     icu61/i18n/decNumber.cpp:2963:30: warning: array subscript is above array bounds [-Warray-bounds]
     icu61/i18n/decNumber.cpp:2963:43: warning: array subscript is above array bounds [-Warray-bounds]
     icu61/i18n/decNumber.cpp:2980:30: warning: array subscript is above array bounds [-Warray-bounds]
     icu61/i18n/decNumber.cpp:2980:43: warning: array subscript is above array bounds [-Warray-bounds]
Flavor: r-devel-windows-ix86+x86_64